NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

pgAdmin 4 vulnerable to directory traversalGHSA-9crj-hpxh-f6qg

MEDIUMFix: akshay-joshi/pgadmin4@64d7289

GHSA-9crj-hpxh-f6qg is a medium-severity (CVSS 6.5) Path Traversal vulnerability in pgadmin4. A fix is available for pgadmin4 — see the affected versions and patch details below.

Also known asCVE-2023-0241PYSEC-2026-1771
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9crj-hpxh-f6qg.

EPSS Exploitation Probability

via FIRST.org ↗
8.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.75%4.06%7.38%10.7%2.6%8.8%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pgadmin4

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

pgAdmin 4 versions prior to v6.19 contains a directory traversal vulnerability. A user of the product may change another user's settings or alter the database.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpgadmin4all versions6.19pip install --upgrade 'pgadmin4==6.19'

Affected Products

1 product · 1 configurations
Application
pgadmin 4pgadmin
< 6.19
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pgadmin4, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pgadmin4 to 6.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9crj-hpxh-f6qg is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

pgAdmin 4 versions prior to v6.19 contains a directory traversal vulnerability. A user of the product may change another user's settings or alter the database.
O3 Security · Impact-Aware SCA

Is GHSA-9crj-hpxh-f6qg in your dependencies?

Find it across PyPI, including transitive dependencies.

pgAdmin 4 vulnerable to directory traversal (Medium 6.5)