NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Drupal core Multiple vulnerabilities due to the use of the third-party library Archive_TarGHSA-98h9-727m-44qv

HIGH

GHSA-98h9-727m-44qv is a high-severity (CVSS 8.1) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

3 pkgs affected
🐘drupal/core🐘drupal/core🐘drupal/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Drupal project uses the third-party library Archive_Tar, which has released a security improvement that is needed to protect some Drupal configurations.

Multiple vulnerabilities are possible if Drupal is configured to allow .tar, .tar.gz, .bz2 or .tlz file uploads and processes them.

The latest versions of Drupal update Archive_Tar to 1.4.9 to mitigate the file processing vulnerabilities.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 7.0.0&&< 7.697.69composer require drupal/core:^7.69
🐘Packagistdrupal/core≥ 8.0.0&&< 8.7.118.7.11composer require drupal/core:^8.7.11
🐘Packagistdrupal/core≥ 8.8.0&&< 8.8.18.8.1composer require drupal/core:^8.8.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 7.69 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-98h9-727m-44qv is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The Drupal project uses the third-party library [Archive_Tar](https://pear.php.net/package/Archive_Tar/), which has released a security improvement that is needed to protect some Drupal configurations. Multiple vulnerabilities are possible if Drupal is configured to allow .tar, .tar.gz, .bz2 or .tlz file uploads and processes them. The latest versions of Drupal update Archive_Tar to 1.4.9 to mitigate the file processing vulnerabilities.
O3 Security · Impact-Aware SCA

Is GHSA-98h9-727m-44qv in your dependencies?

Find it across Packagist, including transitive dependencies.

Drupal core Multiple vulnerabilities due to the use of the…