NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
LOW severity

Spina Cross-site Scripting vulnerabilityGHSA-97wh-6hmj-g8j9

LOWFix: spinacms/spina@9adfe7b

GHSA-97wh-6hmj-g8j9 is a low-severity (CVSS 3.5) Cross-site Scripting (XSS) vulnerability in spina. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for spina — see the affected versions and patch details below.

Also known asCVE-2023-3445
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-97wh-6hmj-g8j9.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.35%0.71%1.06%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎spina

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site Scripting (XSS) - Stored in GitHub repository spinacms/spina prior to 2.15.1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsspinaall versions2.15.1bundle update spina --conservative

Affected Products

1 product · 1 configurations
Application
spinadenkgroot
< 2.15.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for spina, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update spina to 2.15.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-97wh-6hmj-g8j9 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) - Stored in GitHub repository spinacms/spina prior to 2.15.1.
O3 Security · Impact-Aware SCA

Is GHSA-97wh-6hmj-g8j9 in your dependencies?

Find it across RubyGems, including transitive dependencies.

Spina Cross-site Scripting vulnerability (Low 3.5)