NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

AIOHTTP is vulnerable to HTTP Request/Response Smuggling through incorrect parsing of chunked trailer sectionsGHSA-9548-qrrj-x5pj

Fix: aio-libs/aiohttp@e8d774f

GHSA-9548-qrrj-x5pj is a CWE-444 vulnerability in aiohttp. A fix is available for aiohttp — see the affected versions and patch details below.

Also known asCVE-2025-53643PYSEC-2026-1104
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9548-qrrj-x5pj.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs29th percentile — riskier than 29% of all scored CVEsHighest risk
0.00%0.29%0.57%0.85%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍aiohttp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.12.14, the Python parser is vulnerable to a request smuggling vulnerability due to not parsing trailer sections of an HTTP request. If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or AIOHTTP_NO_EXTENSIONS is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections. Version 3.12.14 contains a patch for this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIaiohttpall versions3.12.14pip install --upgrade 'aiohttp==3.12.14'

Affected Products

1 product · 1 configurations
Application
aiohttpaiohttp
< 3.12.14
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aiohttp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update aiohttp to 3.12.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9548-qrrj-x5pj is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

A low impact HTTP request smuggling flaw was found in the aiohttp Python library, which is shipped in a number of Red Hat offerings, including Red Hat Ansible Automation Platform, Red Hat OpenShift AI, and Red Hat Enterprise Linux AI. The pure-Python HTTP parser in aiohttp does not parse trailer sections of an HTTP…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for GHSA-9548-qrrj-x5pj (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Ansible Automation Platform 2.5 for RHEL 8automation-controller-0:4.6.25-1.el8apRHSA-2026:1506
Red Hat Ansible Automation Platform 2.6 for RHEL 9automation-controller-0:4.7.8-1.el9apRHSA-2026:1249
Red Hat Satellite 6.18 for RHEL 9python3.12-aiohttp-0:3.13.3-1.el9pcRHSA-2026:2760
Red Hat Ansible Automation Platform 2.6ansible-automation-platform-26/ee-supported-rhel9:1772508458RHSA-2026:3960
Red Hat OpenShift AI 2.22rhoai/odh-feature-server-rhel9:v2.22.3-1763565765RHSA-2025:22759
Red Hat OpenShift AI 2.25rhoai/odh-feature-server-rhel9:v2.25.1-1765354568RHSA-2025:23531
Red Hat OpenShift Service Mesh 3.0openshift-service-mesh/istio-proxyv2-rhel9:1.24.6-1764181669RHSA-2025:22939
Red Hat OpenShift Service Mesh 3.1openshift-service-mesh/istio-proxyv2-rhel9:1.26.6-1764332723RHSA-2025:22944

Frequently Asked Questions

### Summary The Python parser is vulnerable to a request smuggling vulnerability due to not parsing trailer sections of an HTTP request. ### Impact If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or AIOHTTP_NO_EXTENSIONS is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections. ---- Patch: https://github.com/aio-libs/aiohttp/commit/e8d774f635dc6d1cd3174d0e38891da5de0e2b6a
O3 Security · Impact-Aware SCA

Is GHSA-9548-qrrj-x5pj in your dependencies?

Find it across PyPI, including transitive dependencies.

AIOHTTP is vulnerable to HTTP Request/Response…