CVE-2025-53643 — aiohttp
Fix: aio-libs/aiohttp@e8d774fCVE-2025-53643 is a CWE-444 vulnerability in aiohttp. A fix is available for aiohttp — see the affected versions and patch details below.
AIOHTTP is vulnerable to HTTP Request/Response Smuggling through incorrect parsing of chunked trailer sections
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-53643.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
aiohttpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.12.14, the Python parser is vulnerable to a request smuggling vulnerability due to not parsing trailer sections of an HTTP request. If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or AIOHTTP_NO_EXTENSIONS is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections. Version 3.12.14 contains a patch for this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | aiohttp | all versions | 3.12.14pip install --upgrade 'aiohttp==3.12.14' |
Affected Products
aiohttpaiohttpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aiohttp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update aiohttp to 3.12.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-53643 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
A low impact HTTP request smuggling flaw was found in the aiohttp Python library, which is shipped in a number of Red Hat offerings, including Red Hat Ansible Automation Platform, Red Hat OpenShift AI, and Red Hat Enterprise Linux AI. The pure-Python HTTP parser in aiohttp does not parse trailer sections of an HTTP…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-53643 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | automation-controller-0:4.6.25-1.el8ap | RHSA-2026:1506 |
| Red Hat Ansible Automation Platform 2.6 for RHEL 9 | automation-controller-0:4.7.8-1.el9ap | RHSA-2026:1249 |
| Red Hat Satellite 6.18 for RHEL 9 | python3.12-aiohttp-0:3.13.3-1.el9pc | RHSA-2026:2760 |
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-26/ee-supported-rhel9:1772508458 | RHSA-2026:3960 |
| Red Hat OpenShift AI 2.22 | rhoai/odh-feature-server-rhel9:v2.22.3-1763565765 | RHSA-2025:22759 |
| Red Hat OpenShift AI 2.25 | rhoai/odh-feature-server-rhel9:v2.25.1-1765354568 | RHSA-2025:23531 |
| Red Hat OpenShift Service Mesh 3.0 | openshift-service-mesh/istio-proxyv2-rhel9:1.24.6-1764181669 | RHSA-2025:22939 |
| Red Hat OpenShift Service Mesh 3.1 | openshift-service-mesh/istio-proxyv2-rhel9:1.26.6-1764332723 | RHSA-2025:22944 |
Frequently Asked Questions
Is CVE-2025-53643 in your dependencies?
Find it across PyPI, including transitive dependencies.