NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

npm CLI exposing sensitive information through logsGHSA-93f3-23rq-pjfp

MEDIUMFix: npm/cli@a9857b8

GHSA-93f3-23rq-pjfp is a medium-severity (CVSS 4.4) CWE-532 vulnerability in npm. A fix is available for npm — see the affected versions and patch details below.

Also known asCVE-2020-15095
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs35th percentile — riskier than 35% of all scored CVEsHighest risk
0.00%0.31%0.61%0.92%0.1%0.4%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

7Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
npmnpm
24.1Mdownloads / week

Description

Versions of the npm CLI prior to 6.14.6 are vulnerable to an information exposure vulnerability through log files. The CLI supports URLs like <protocol>://[<user>[:<password>]@]<hostname>[:<port>][:][/]<path>. The password value is not redacted and is printed to stdout and also to any generated log files.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmnpmall versions6.14.6npm install npm@6.14.6

Affected Products

3 products · 4 configurations
OS
fedorafedoraproject
1 version
33
Application
npmnpmjs
< 6.14.6
range
OS
leapopensuse
2 versions
15.115.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for npm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update npm to 6.14.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-93f3-23rq-pjfp is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
Do not provide a password to npm via the cli to avoid it from being entered into the logs and stdout, or use ssh instead.
Source: Red Hat security advisory for GHSA-93f3-23rq-pjfp (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 8nodejs:12-8020020201007080935.4cda2c84RHSA-2020:4272
Red Hat Enterprise Linux 8nodejs:10-8030020210118191659.229f0a1cRHSA-2021:0548
Red Hat Enterprise Linux 8.1 Extended Update Supportnodejs:12-8010020201006223055.c27ad7f8RHSA-2020:4903
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-nodejs12-nodejs-0:12.18.4-3.el7RHSA-2020:5086
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-nodejs10-nodejs-0:10.23.1-2.el7RHSA-2021:0521

Frequently Asked Questions

Versions of the npm CLI prior to 6.14.6 are vulnerable to an information exposure vulnerability through log files. The CLI supports URLs like `<protocol>://[<user>[:<password>]@]<hostname>[:<port>][:][/]<path>`. The password value is not redacted and is printed to stdout and also to any generated log files.
O3 Security · Impact-Aware SCA

Is GHSA-93f3-23rq-pjfp in your dependencies?

Find it across npm, including transitive dependencies.

npm CLI exposing sensitive information through logs