NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2019-16777 — npm

MEDIUM

CVE-2019-16777 is a medium-severity (CVSS 6.5) Path Traversal vulnerability in npm. A fix is available for npm — see the affected versions and patch details below.

npm Vulnerable to Global node_modules Binary Overwrite

Also known asGHSA-4328-8hgf-7wjr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.89%1.78%2.66%0.3%2.1%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

7Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
npmnpm
24.2Mdownloads / week

Description

Versions of the npm CLI prior to 6.13.4 are vulnerable to a Global node_modules Binary Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations.

For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the first binary. This will not overwrite system binaries but only binaries put into the global node_modules directory.

This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

Recommendation

Upgrade to version 6.13.4 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmnpmall versions6.13.4npm install npm@6.13.4

Affected Products

6 products · 6 configurations
OS
fedorafedoraproject
1 version
31
Application
npmnpmjs
< 6.13.4
range
OS
leapopensuse
1 version
15.1
Application
graalvmoracle
1 version
19.3.0.2
OS
enterprise linuxredhat
1 version
8.0
OS
enterprise linux eusredhat
1 version
8.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for npm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update npm to 6.13.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16777 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
Red Hat Enterprise Linux 8nodejs:12-8010020200116150415.c27ad7f8RHEA-2020:0330
Red Hat Enterprise Linux 8nodejs:10-8010020200213140254.c27ad7f8RHSA-2020:0579
Red Hat Enterprise Linux 8.0 Update Services for SAP Solutionsnodejs:10-8000020200214110450.f8e95b4eRHSA-2020:0573
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-nodejs10-nodejs-0:10.19.0-1.el7RHSA-2020:0597
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-nodejs12-nodejs-0:12.16.1-1.el7RHSA-2020:0602
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-nodejs8-nodejs-0:8.17.0-2.el7RHSA-2020:2625

Frequently Asked Questions

Versions of the npm CLI prior to 6.13.4 are vulnerable to a Global node_modules Binary Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a `serve` binary, any subsequent installs of packages that also create a `serve` binary would overwrite the first binary. This will not overwrite system binaries but only binaries put into the global node_modules directory. This behavior is still allowed in local installations and also through install scripts. This vulnerability
O3 Security · Impact-Aware SCA

Is CVE-2019-16777 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2019-16777: npm — Fixed in 6.13.4