Silverstripe Brute force bypass on default adminGHSA-8v6m-7f5v-hhx6
CRITICALFix: silverstripe/silverstripe-framework@f32c893GHSA-8v6m-7f5v-hhx6 is a critical-severity (CVSS 9.1) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
Real-World Exposure
silverstripe/framework🐘silverstripe/framework🐘silverstripe/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Default Administrator accounts were not subject to the same brute force protection afforded to other Member accounts. Failed login counts were not logged for default admins resulting in unlimited attempts on the default admin username and password.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | ≥ 3.1.18&&< 3.1.19 | 3.1.19composer require silverstripe/framework:^3.1.19 |
| 🐘Packagist | silverstripe/framework | ≥ 3.2.3&&< 3.2.4 | 3.2.4composer require silverstripe/framework:^3.2.4 |
| 🐘Packagist | silverstripe/framework | ≥ 3.3.1&&< 3.3.2 | 3.3.2composer require silverstripe/framework:^3.3.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 3.1.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8v6m-7f5v-hhx6 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-8v6m-7f5v-hhx6 in your dependencies?
Find it across Packagist, including transitive dependencies.