GHSA-8q8v-28rm-qw4w is a high-severity (CVSS 8.8) vulnerability in borgbackup. A fix is available for borgbackup — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
borgbackupReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | borgbackup | ≥ 1.1.0b1&&< 1.1.3 | 1.1.3pip install --upgrade 'borgbackup==1.1.3' |
Affected Products
borgborgbackupDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for borgbackup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update borgbackup to 1.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8q8v-28rm-qw4w is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-8q8v-28rm-qw4w in your dependencies?
Find it across PyPI, including transitive dependencies.