`chainId` may be outdated if user changes chains as part of connection in @web3-reactGHSA-8pf3-6fgr-3g3g
MEDIUMFix: Uniswap/web3-react#749GHSA-8pf3-6fgr-3g3g is a medium-severity (CVSS 5.2) CWE-362 vulnerability in @web3-react/coinbase-wallet. A fix is available for @web3-react/coinbase-wallet — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-8pf3-6fgr-3g3g.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@web3-react/coinbase-walletnpm@web3-react/eip1193npm@web3-react/metamasknpmDescription
Impact
chainId may be outdated if the user changes chains as part of the connection flow. This means that the value of chainId returned by useWeb3React() may be incorrect. In an application, this means that any data derived from chainId could be incorrect.
For example, if a swapping application derives a wrapped token contract address from the chainId and a user has changed chains as part of their connection flow the application could cause the user to send funds to the incorrect address when wrapping. This is a common approach when using other foundational libraries like ethers, and most users of v8 will want to upgrade past the affected versions.
Patches
Patched in https://github.com/Uniswap/web3-react/pull/749. Users of [email protected] should upgrade to at least:
- @web3-react/coinbase-wallet@^8.0.35-beta.0
- @web3-react/eip1193@^8.0.27-beta.0
- @web3-react/metamask@^8.0.30-beta.0
- @web3-react/walletconnect@^8.0.37-beta.0
Workarounds
N/A
References
N/A
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @web3-react/coinbase-wallet | ≥ 6.0.0&&< 8.0.35-beta.0 | 8.0.35-beta.0npm install @web3-react/coinbase-wallet@8.0.35-beta.0 |
| 📦npm | @web3-react/eip1193 | ≥ 6.0.0&&< 8.0.27-beta | 8.0.27-betanpm install @web3-react/eip1193@8.0.27-beta |
| 📦npm | @web3-react/metamask | ≥ 6.0.0&&< 8.0.30-beta.0 | 8.0.30-beta.0npm install @web3-react/metamask@8.0.30-beta.0 |
| 📦npm | @web3-react/walletconnect | ≥ 6.0.0&&< 8.0.37-beta.0 | 8.0.37-beta.0npm install @web3-react/walletconnect@8.0.37-beta.0 |
Affected Products
web3-react coinbase-walletuniswapweb3-react eip1193uniswapweb3-react metamaskuniswapweb3-react walletconnectuniswapDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @web3-react/coinbase-wallet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @web3-react/coinbase-wallet to 8.0.35-beta.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8pf3-6fgr-3g3g is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-8pf3-6fgr-3g3g in your dependencies?
Find it across npm, including transitive dependencies.