Insecure Deserialization in TYPO3 CMSGHSA-8h28-f46f-m87h
GHSA-8h28-f46f-m87h is a remote code execution vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that the Form Framework (system extension "form") is vulnerable to Insecure Deserialization when being used with the additional PHP PECL package “yaml”, which is capable of unserializing YAML contents to PHP objects. A valid backend user account as well as having PHP setting "yaml.decode_php" enabled is needed to exploit this vulnerability (which is the default value according to PHP documentation).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 8.5.0&&< 8.7.17 | 8.7.17composer require typo3/cms:^8.7.17 |
| 🐘Packagist | typo3/cms | ≥ 9.0.0&&< 9.3.2 | 9.3.2composer require typo3/cms:^9.3.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 8.7.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8h28-f46f-m87h is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is GHSA-8h28-f46f-m87h in your dependencies?
Find it across Packagist, including transitive dependencies.