NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

qcubed SQL injection vulnerability in profile.php via the strQuery parameterGHSA-8fj6-pc5r-347q

CRITICALFix: qcubed/qcubed#1320

GHSA-8fj6-pc5r-347q is a critical-severity (CVSS 9.8) SQL Injection vulnerability in qcubed/qcubed. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for qcubed/qcubed — see the affected versions and patch details below.

Also known asCVE-2020-24913
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
40.9%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
39.6%41.4%43.2%45.0%43.1%40.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘qcubed/qcubed

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A SQL injection vulnerability in qcubed (all versions including 3.1.1) in profile.php via the strQuery parameter allows an unauthenticated attacker to access the database by injecting SQL code via a crafted POST request.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistqcubed/qcubedall versions3.2composer require qcubed/qcubed:^3.2

Affected Products

1 product · 1 configurations
Application
qcubedqcubed
≤ 3.1.1
range
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for qcubed/qcubed, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update qcubed/qcubed to 3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8fj6-pc5r-347q is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

A SQL injection vulnerability in qcubed (all versions including 3.1.1) in profile.php via the strQuery parameter allows an unauthenticated attacker to access the database by injecting SQL code via a crafted POST request.
O3 Security · Impact-Aware SCA

Is GHSA-8fj6-pc5r-347q in your dependencies?

Find it across Packagist, including transitive dependencies.

qcubed SQL injection vulnerability in profile.php via the…