CVE-2020-24914 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in qcubed/qcubed. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for qcubed/qcubed — see the affected versions and patch details below.
qcubed PHP object injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
qcubed/qcubedReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A PHP object injection bug in profile.php in qcubed (all versions including 3.1.1) unserializes the untrusted data of the POST-variable "strProfileData" and allows an unauthenticated attacker to execute code via a crafted POST request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | qcubed/qcubed | all versions | 3.2composer require qcubed/qcubed:^3.2 |
Affected Products
qcubedqcubedResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for qcubed/qcubed, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update qcubed/qcubed to 3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-24914 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2020-24914 in your dependencies?
Find it across Packagist, including transitive dependencies.