tar-fs can extract outside the specified dir with a specific tarballGHSA-8cj5-5rvv-wf4v
Fix: mafintosh/tar-fs@647447bGHSA-8cj5-5rvv-wf4v is a Path Traversal vulnerability in tar-fs. A fix is available for tar-fs — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-8cj5-5rvv-wf4v.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
tar-fsnpmDescription
Impact
v3.0.8, v2.1.2, v1.16.4 and below
Patches
Has been patched in 3.0.9, 2.1.3, and 1.16.5
Workarounds
You can use the ignore option to ignore non files/directories.
ignore (_, header) {
// pass files & directories, ignore e.g. symlinks
return header.type !== 'file' && header.type !== 'directory'
}
Credit
Thank you Caleb Brown from Google Open Source Security Team for reporting this in detail.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | tar-fs | all versions | 1.16.5npm install tar-fs@1.16.5 |
| 📦npm | tar-fs | ≥ 2.0.0&&< 2.1.3 | 2.1.3npm install tar-fs@2.1.3 |
| 📦npm | tar-fs | ≥ 3.0.0&&< 3.0.9 | 3.0.9npm install tar-fs@3.0.9 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tar-fs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tar-fs to 1.16.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8cj5-5rvv-wf4v is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability in tar-fs is Important not a moderate flaw, primarily due to its ability to bypass directory confinement during tarball extraction. The core issue—path traversal via crafted archive entries—allows attackers to write files outside the intended extraction directory, potentially overwriting system…
Mitigation is either unavailable or does not meet Red Hat Product Security standards for usability, deployment, applicability, or stability.Source: Red Hat security advisory for GHSA-8cj5-5rvv-wf4v (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Developer Hub 1.5 | rhdh/rhdh-hub-rhel9:1.5.3-1752159545 | RHSA-2025:10992 |
| Red Hat Developer Hub 1.6 | rhdh/rhdh-hub-rhel9:1.6.2-1750887220 | RHSA-2025:9966 |
| Red Hat Developer Hub 1.7 | rhdh/rhdh-hub-rhel9:1.7.0-1754936470 | RHSA-2025:14090 |
| Red Hat OpenShift Dev Spaces (RHOSDS) 3.23 | devspaces/code-rhel9:3.23-1757618807 | RHSA-2025:15847 |
Frequently Asked Questions
Is GHSA-8cj5-5rvv-wf4v in your dependencies?
Find it across npm, including transitive dependencies.