NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Cloudflare Wrangler directory traversal vulnerabilityGHSA-8c93-4hch-xgxp

MEDIUMFix: cloudflare/workers-sdk#3498

GHSA-8c93-4hch-xgxp is a medium-severity (CVSS 5.7) Path Traversal vulnerability in wrangler. A fix is available for wrangler — see the affected versions and patch details below.

Also known asCVE-2023-3348
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-8c93-4hch-xgxp.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.88%1.32%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

297other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
wranglernpm
40.7Mdownloads / week

Description

Impact

The Wrangler command line tool (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.

Patches

Wrangler2: Upgrade to v2.20.1 or higher. Wrangler3: Upgrade to v3.1.1 or higher.

References

Workers SDK on Github Wrangler docs CVE-2023-3348

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmwranglerall versions2.20.1npm install wrangler@2.20.1

Affected Products

1 product · 1 configurations
Application
wranglercloudflare
< 3.1.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wrangler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wrangler to 2.20.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8c93-4hch-xgxp is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Impact The Wrangler command line tool (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server. ### Patches Wrangler2: Upgrade to v2.20.1 or higher. Wrangler3: Upgrade to v3.1.1 or higher. ### References [Workers SDK on Github](https://github.com/cloudflare/workers-sdk) [
O3 Security · Impact-Aware SCA

Is GHSA-8c93-4hch-xgxp in your dependencies?

Find it across npm, including transitive dependencies.

Cloudflare Wrangler directory traversal vulnerability