NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

XXE vulnerability in XSLT parsing in `org.hl7.fhir.publisher`GHSA-8c3x-hq82-gjcm

HIGHFix: HL7/fhir-ig-publisher@3560de2

GHSA-8c3x-hq82-gjcm is a high-severity (CVSS 8.6) XML External Entity (XXE) vulnerability in org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli. A fix is available for org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli — see the affected versions and patch details below.

Also known asCVE-2024-52807
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.36%0.71%1.07%0.0%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli☕org.hl7.fhir.publisher:org.hl7.fhir.publisher.core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

XSLT transforms performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag ( ]> could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.publisher is being used to within a host where external clients can submit XML.

A previous release provided an incomplete solution revealed by new testing.

Patches

This issue has been patched as of version 1.7.4

Workarounds

None

References

Previous Advisory for Incomplete solution MITRE CWE OWASP XML External Entity Prevention Cheat Sheet

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.hl7.fhir.publisher:org.hl7.fhir.publisher.cliall versions1.7.4org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli:1.7.4
☕Mavenorg.hl7.fhir.publisher:org.hl7.fhir.publisher.coreall versions1.7.4org.hl7.fhir.publisher:org.hl7.fhir.publisher.core:1.7.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli to 1.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8c3x-hq82-gjcm is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact XSLT transforms performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag ( ]> could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.publisher is being used to within a host where external clients can submit XML. A previous release provided an incomplete solution revealed by new testing. ### Patches This issue has been patched as of version 1.7.4 ### Workarounds None ### References [Previous Advisory for Incomplete solution](https://github.com/HL7/fhir-ig-publisher/
O3 Security · Impact-Aware SCA

Is GHSA-8c3x-hq82-gjcm in your dependencies?

Find it across Maven, including transitive dependencies.

XXE vulnerability in XSLT parsing in `org.hl7.fhir.publisher`