NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2024-52807 — org.hl7.fhir.publisher.cli

HIGHFix: HL7/fhir-ig-publisher@3560de2

CVE-2024-52807 is a high-severity (CVSS 8.6) XML External Entity (XXE) vulnerability in org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli. A fix is available for org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli — see the affected versions and patch details below.

XXE vulnerability in XSLT parsing in `org.hl7.fhir.publisher`

Also known asGHSA-8c3x-hq82-gjcm
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.35%0.71%1.06%0.0%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli☕org.hl7.fhir.publisher:org.hl7.fhir.publisher.core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The HL7 FHIR IG publisher is a tool to take a set of inputs and create a standard FHIR IG. Prior to version 1.7.4, XSLT transforms performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag ( ]> could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.publisher is being used to within a host where external clients can submit XML. A previous release provided an incomplete solution revealed by new testing. This issue has been patched as of version 1.7.4. No known workarounds are available.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.hl7.fhir.publisher:org.hl7.fhir.publisher.cliall versions1.7.4org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli:1.7.4
☕Mavenorg.hl7.fhir.publisher:org.hl7.fhir.publisher.coreall versions1.7.4org.hl7.fhir.publisher:org.hl7.fhir.publisher.core:1.7.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli to 1.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-52807 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The HL7 FHIR IG publisher is a tool to take a set of inputs and create a standard FHIR IG. Prior to version 1.7.4, XSLT transforms performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag `( ]>` could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.publisher is being used to within a host where external clients can submit XML. A previous release provided an incomplete solution revealed by new testing. This issue has been patched as of version 1.7.4. No known workarounds are availa
O3 Security · Impact-Aware SCA

Is CVE-2024-52807 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-52807: org.hl7.fhir.publisher XXE — Fixed in 1.7.4