NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CPU exhaustion in SvelteKit remote form deserialization (experimental only)GHSA-88qp-p4qg-rqm6

Fix: sveltejs/kit@3e607b3

GHSA-88qp-p4qg-rqm6 is a Uncontrolled Resource Consumption vulnerability in @sveltejs/kit. A fix is available for @sveltejs/kit — see the affected versions and patch details below.

Also known asCVE-2026-82261
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-88qp-p4qg-rqm6.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk
0.00%0.33%0.66%0.99%0.3%0.5%0.5%0.5%Sep 26Nov 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

216other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@sveltejs/kitnpm
5.0Mdownloads / week

Description

SvelteKit (@sveltejs/kit) versions >=2.49.0 and <=2.52.1 with experimental remote functions and form enabled contain a CPU exhaustion vulnerability in form deserialization. An attacker can send malformed form data to cause the server to become unresponsive while processing the request, resulting in denial of service. Fixed in 2.52.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@sveltejs/kit≥ 2.49.0&&< 2.52.22.52.2npm install @sveltejs/kit@2.52.2

Affected Products

1 product · 1 configurations
Application
sveltekitsvelte
≥ 2.49.0 && < 2.52.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @sveltejs/kit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @sveltejs/kit to 2.52.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-88qp-p4qg-rqm6 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Versions of `@sveltejs/kit` prior to 2.52.2 with remote functions enabled are vulnerable to CPU exhaustion. Malformed form data can cause the server to become unresponsive while processing a request, resulting in denial of service. Only applications using both `experimental.remoteFunctions` and `form` are vulnerable.
O3 Security · Impact-Aware SCA

Is GHSA-88qp-p4qg-rqm6 in your dependencies?

Find it across npm, including transitive dependencies.

CPU exhaustion in SvelteKit remote form deserialization…