Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

SvelteKit: Big remote form function payloads can cause Node process to crashGHSA-wqjv-9729-c5q2

MEDIUMFix: sveltejs/kit#16219

GHSA-wqjv-9729-c5q2 is a medium-severity (CVSS 5.3) Uncontrolled Resource Consumption vulnerability in @sveltejs/kit. A fix is available for @sveltejs/kit — see the affected versions and patch details below.

Also known asCVE-2026-82256
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-wqjv-9729-c5q2.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs36th percentile — riskier than 36% of all scored CVEsHighest risk
0.00%0.31%0.62%0.92%0.2%0.4%0.4%Sep 26Oct 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

GHSA-wqjv-9729-c5q2 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 395,249 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

216other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@sveltejs/kitnpm
2.2Mdownloads / week

Description

SvelteKit before 2.69.1 fails to properly validate remote form function payload sizes, allowing attackers to crash the Node process by sending large payloads. Repeated exploitation causes denial of service by repeatedly crashing the application process.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@sveltejs/kitall versions2.69.1npm install @sveltejs/kit@2.69.1

Affected Products

1 product · 1 configurations
Application
sveltekitsvelte
< 2.69.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @sveltejs/kit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @sveltejs/kit to 2.69.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wqjv-9729-c5q2 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Big remote form function payloads can cause the Node process to crash. Doing this repeatedly can cause DoS.
O3 Security · Impact-Aware SCA

Is GHSA-wqjv-9729-c5q2 in your dependencies?

Find it across npm, including transitive dependencies.

SvelteKit: Big remote form function payloads can cause…