NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Improper Restriction of XML External Entity Reference in iTextGHSA-86p9-x5pw-94qx

HIGH

GHSA-86p9-x5pw-94qx is a high-severity (CVSS 8.8) XML External Entity (XXE) vulnerability in com.itextpdf:itextpdf. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for com.itextpdf:itextpdf — see the affected versions and patch details below.

Also known asCVE-2017-9096
Published
Updated
Affected
3 pkgs
Patched
2 / 3
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
9.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
6.94%8.18%9.41%10.6%7.6%9.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕com.itextpdf:itextpdf☕com.itextpdf:itextpdf☕com.lowagie:itext

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The XML parsers in iText before 5.5.12 and 7.x before 7.0.3 do not disable external entities, which might allow remote attackers to conduct XML external entity (XXE) attacks via a crafted PDF.

Affected Packages

3 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.itextpdf:itextpdfall versions5.5.12com.itextpdf:itextpdf:5.5.12
☕Mavencom.itextpdf:itextpdf≥ 7.0.0&&< 7.0.37.0.3com.itextpdf:itextpdf:7.0.3
☕Mavencom.lowagie:itextall versionsNo fix

Affected Products

1 product · 4 configurations
Application
itextitextpdf
< 5.5.12
3 versions
7.0.07.0.17.0.2
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.itextpdf:itextpdf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.itextpdf:itextpdf to 5.5.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-86p9-x5pw-94qx is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The XML parsers in iText before 5.5.12 and 7.x before 7.0.3 do not disable external entities, which might allow remote attackers to conduct XML external entity (XXE) attacks via a crafted PDF.
O3 Security · Impact-Aware SCA

Is GHSA-86p9-x5pw-94qx in your dependencies?

Find it across Maven, including transitive dependencies.

Improper Restriction of XML External Entity Reference in…