CVE-2017-9096 — itextpdf
HIGHCVE-2017-9096 is a high-severity (CVSS 8.8) XML External Entity (XXE) vulnerability in com.itextpdf:itextpdf. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for com.itextpdf:itextpdf — see the affected versions and patch details below.
Improper Restriction of XML External Entity Reference in iText
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.itextpdf:itextpdf☕com.itextpdf:itextpdf☕com.lowagie:itextReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The XML parsers in iText before 5.5.12 and 7.x before 7.0.3 do not disable external entities, which might allow remote attackers to conduct XML external entity (XXE) attacks via a crafted PDF.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.itextpdf:itextpdf | all versions | 5.5.12com.itextpdf:itextpdf:5.5.12 |
| ☕Maven | com.itextpdf:itextpdf | ≥ 7.0.0&&< 7.0.3 | 7.0.3com.itextpdf:itextpdf:7.0.3 |
| ☕Maven | com.lowagie:itext | all versions | No fix |
Affected Products
itextitextpdfResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.itextpdf:itextpdf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.itextpdf:itextpdf to 5.5.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-9096 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-9096 in your dependencies?
Find it across Maven, including transitive dependencies.