NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Netmaker Vulnerable to Privilege Escalation From Non Admin To Admin UserGHSA-826j-8wp2-4x6q

HIGH

GHSA-826j-8wp2-4x6q is a high-severity (CVSS 8.8) CWE-915 vulnerability in github.com/gravitl/netmaker. A fix is available for github.com/gravitl/netmaker — see the affected versions and patch details below.

Also known asCVE-2023-32079GO-2023-2025
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-826j-8wp2-4x6q.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.05%0.55%1.05%1.54%0.6%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/gravitl/netmaker🐹github.com/gravitl/netmaker

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A Mass assignment vulnerability was found allowing a non-admin user to escalate privileges to admin user.

Patches

Issue is patched in 0.17.1, and fixed in 0.18.6+.

If Users are using 0.17.1, they should run "docker pull gravitl/netmaker:v0.17.1" and "docker-compose up -d". This will switch them to the patched users

If users are using v0.18.0-0.18.5, they should upgrade to v0.18.6 or later.

Workarounds

If using 0.17.1, can just pull the latest docker image of backend and restart server.

References

Credit to Project Discovery, and in particular https://github.com/rootxharsh , https://github.com/iamnoooob, and https://github.com/projectdiscovery

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/gravitl/netmakerall versions0.17.1go get github.com/gravitl/netmaker@v0.17.1
🐹Gogithub.com/gravitl/netmaker≥ 0.18.0&&< 0.18.60.18.6go get github.com/gravitl/netmaker@v0.18.6

Affected Products

1 product · 2 configurations
Application
netmakernetmaker
≥ 0.18.0 && ≤ 0.18.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/gravitl/netmaker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/gravitl/netmaker to 0.17.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-826j-8wp2-4x6q is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact A Mass assignment vulnerability was found allowing a non-admin user to escalate privileges to admin user. ### Patches Issue is patched in 0.17.1, and fixed in 0.18.6+. If Users are using 0.17.1, they should run "docker pull gravitl/netmaker:v0.17.1" and "docker-compose up -d". This will switch them to the patched users If users are using v0.18.0-0.18.5, they should upgrade to v0.18.6 or later. ### Workarounds If using 0.17.1, can just pull the latest docker image of backend and restart server. ### References Credit to Project Discovery, and in particular https://github.com/root
O3 Security · Impact-Aware SCA

Is GHSA-826j-8wp2-4x6q in your dependencies?

Find it across Go, including transitive dependencies.

Netmaker Vulnerable to Privilege Escalation From Non…