CVE-2023-32079 — netmaker
HIGHCVE-2023-32079 is a high-severity (CVSS 8.8) CWE-915 vulnerability in github.com/gravitl/netmaker. A fix is available for github.com/gravitl/netmaker — see the affected versions and patch details below.
Netmaker Privilige Escalation Vulnerability
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-32079.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/gravitl/netmaker🐹github.com/gravitl/netmakerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Netmaker makes networks with WireGuard. A Mass assignment vulnerability was found in versions prior to 0.17.1 and 0.18.6 that allows a non-admin user to escalate privileges to those of an admin user. The issue is patched in 0.17.1 and fixed in 0.18.6. If Users are using 0.17.1, they should run docker pull gravitl/netmaker:v0.17.1 and docker-compose up -d. This will switch them to the patched users If users are using v0.18.0-0.18.5, they should upgrade to v0.18.6 or later. As a workaround, someone using version 0.17.1 can pull the latest docker image of the backend and restart the server.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/gravitl/netmaker | all versions | 0.17.1go get github.com/gravitl/netmaker@v0.17.1 |
| 🐹Go | github.com/gravitl/netmaker | ≥ 0.18.0&&< 0.18.6 | 0.18.6go get github.com/gravitl/netmaker@v0.18.6 |
Affected Products
netmakernetmakerDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/gravitl/netmaker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/gravitl/netmaker to 0.17.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-32079 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-32079 in your dependencies?
Find it across Go, including transitive dependencies.