NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

Missing certificate validation in Apache JMeterGHSA-7v85-6hv2-rwgw

CRITICAL

GHSA-7v85-6hv2-rwgw is a critical-severity (CVSS 9.8) CWE-319 vulnerability in org.apache.jmeter:ApacheJMeter. EPSS puts its 30-day exploitation probability at 11.5% (96th percentile). A fix is available for org.apache.jmeter:ApacheJMeter — see the affected versions and patch details below.

Also known asCVE-2018-1297
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
11.5%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
7.49%11.8%16.1%20.4%18.0%11.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.jmeter:ApacheJMeter

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

When using Distributed Test only (RMI based), Apache JMeter 2.x and 3.x uses an unsecured RMI connection. This could allow an attacker to get Access to JMeterEngine and send unauthorized code.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.jmeter:ApacheJMeterall versions4.0org.apache.jmeter:ApacheJMeter:4.0

Affected Products

1 product · 63 configurations
Application
jmeterapache
22 versions
2.12.22.32.3.12.3.22.3.32.3.42.42.52.5.12.62.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.jmeter:ApacheJMeter, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.jmeter:ApacheJMeter to 4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7v85-6hv2-rwgw is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

When using Distributed Test only (RMI based), Apache JMeter 2.x and 3.x uses an unsecured RMI connection. This could allow an attacker to get Access to JMeterEngine and send unauthorized code.
O3 Security · Impact-Aware SCA

Is GHSA-7v85-6hv2-rwgw in your dependencies?

Find it across Maven, including transitive dependencies.

Missing certificate validation in Apache JMeter (Critical 9.8)