Nomad Panics On Job Submission With Bad Artifact Stanza Source URLGHSA-7v3g-4878-5qrf
MEDIUMGHSA-7v3g-4878-5qrf is a medium-severity (CVSS 6.5) Improper Input Validation vulnerability in github.com/hashicorp/nomad. A fix is available for github.com/hashicorp/nomad — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-7v3g-4878-5qrf.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/nomad🐹github.com/hashicorp/nomadReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
HashiCorp Nomad and Nomad Enterprise 1.0.2 up to 1.2.12, and 1.3.5 jobs submitted with an artifact stanza using invalid S3 or GCS URLs can be used to crash client agents. Fixed in 1.2.13, 1.3.6, and 1.4.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/nomad | all versions | 1.2.13go get github.com/hashicorp/nomad@v1.2.13 |
| 🐹Go | github.com/hashicorp/nomad | ≥ 1.3.0&&< 1.3.6 | 1.3.6go get github.com/hashicorp/nomad@v1.3.6 |
Affected Products
nomadhashicorpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/nomad, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/nomad to 1.2.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7v3g-4878-5qrf is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-7v3g-4878-5qrf in your dependencies?
Find it across Go, including transitive dependencies.