CVE-2024-7625 — nomad
MEDIUMCVE-2024-7625 is a medium-severity (CVSS 5.8) CWE-610 vulnerability in github.com/hashicorp/nomad. A fix is available for github.com/hashicorp/nomad — see the affected versions and patch details below.
Nomad Vulnerable to Allocation Directory Escape On Non-Existing File Paths Through Archive Unpacking
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-7625.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/nomad🐹github.com/hashicorp/nomad🐹github.com/hashicorp/nomadReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
In HashiCorp Nomad and Nomad Enterprise from 0.6.1 up to 1.6.13, 1.7.10, and 1.8.2, the archive unpacking process is vulnerable to writes outside the allocation directory during migration of allocation directories when multiple archive headers target the same file. This vulnerability, CVE-2024-7625, is fixed in Nomad 1.6.14, 1.7.11, and 1.8.3. Access or compromise of the Nomad client agent at the source allocation first is a prerequisite for leveraging this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/nomad | ≥ 0.6.1&&< 1.6.14 | 1.6.14go get github.com/hashicorp/nomad@v1.6.14 |
| 🐹Go | github.com/hashicorp/nomad | ≥ 1.7.0&&< 1.7.11 | 1.7.11go get github.com/hashicorp/nomad@v1.7.11 |
| 🐹Go | github.com/hashicorp/nomad | ≥ 1.8.0&&< 1.8.3 | 1.8.3go get github.com/hashicorp/nomad@v1.8.3 |
Affected Products
nomadhashicorpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/nomad, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/nomad to 1.6.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-7625 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2024-7625 in your dependencies?
Find it across Go, including transitive dependencies.