NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Ghost vulnerable to remote code execution in locale setting changeGHSA-7v28-g2pq-ggg8

MEDIUM

GHSA-7v28-g2pq-ggg8 is a medium-severity (CVSS 6.6) vulnerability in ghost. A fix is available for ghost — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Aug 10, 2022 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

8other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ghostnpm
28Kdownloads / week

Description

Impact

A vulnerability in an upstream library means an authenticated attacker can abuse locale input to execute arbitrary commands from a file that has previously been uploaded using the file upload functionality in the post editor.

Patches

Fixed in 5.2.3, all 5.x sites should update as soon as possible. Fixed in 4.48.2, all 4.x sites should update as soon as possible.

Workarounds

Patched versions of Ghost add validation to the locale input to prevent execution of arbitrary files. Updating Ghost is the quickest complete solution.

As a workaround, if for any reason you cannot update your Ghost instance, you can block the POST /ghost/api/admin/settings/ endpoint, which will also disable updating settings for your site.

For more information

If you have any questions or comments about this advisory:

Credits

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmghostall versions4.48.2npm install ghost@4.48.2
📦npmghost≥ 5.0.0&&< 5.2.35.2.3npm install ghost@5.2.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ghost, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ghost to 4.48.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7v28-g2pq-ggg8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact A [vulnerability](https://www.cve.org/CVERecord?id=CVE-2022-24785) in an upstream library means an authenticated attacker can abuse locale input to execute arbitrary commands from a file that has previously been uploaded using the file upload functionality in the post editor. ### Patches Fixed in 5.2.3, all 5.x sites should update as soon as possible. Fixed in 4.48.2, all 4.x sites should update as soon as possible. ### Workarounds Patched versions of Ghost add validation to the locale input to prevent execution of arbitrary files. Updating Ghost is the quickest complete soluti
O3 Security · Impact-Aware SCA

Is GHSA-7v28-g2pq-ggg8 in your dependencies?

Find it across npm, including transitive dependencies.

Ghost vulnerable to remote code execution in locale…