NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

XSS in hello.jsGHSA-7jh9-6cpf-h4m7

CRITICALFix: MrSwitch/hello.js@d6f5137

GHSA-7jh9-6cpf-h4m7 is a critical-severity (CVSS 9.9) Cross-site Scripting (XSS) vulnerability in hellojs. A fix is available for hellojs — see the affected versions and patch details below.

Also known asCVE-2020-7741SNYK-JS-HELLOJS-1014546
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.02%0.67%1.32%1.98%0.5%1.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

16other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
hellojsnpm
8Kdownloads / week

Description

This affects the package hello.js before 1.18.6. The code get the param oauth_redirect from url and pass it to location.assign without any check and sanitisation. So we can simply pass some XSS payloads into the url param oauth_redirect, such as javascript:alert(1).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmhellojsall versions1.18.6npm install hellojs@1.18.6

Affected Products

1 product · 1 configurations
Application
hello.jshello.js_project
< 1.18.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hellojs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update hellojs to 1.18.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7jh9-6cpf-h4m7 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

This affects the package hello.js before 1.18.6. The code get the param oauth_redirect from url and pass it to location.assign without any check and sanitisation. So we can simply pass some XSS payloads into the url param oauth_redirect, such as `javascript:alert(1)`.
O3 Security · Impact-Aware SCA

Is GHSA-7jh9-6cpf-h4m7 in your dependencies?

Find it across npm, including transitive dependencies.

XSS in hello.js (Critical 9.9)