NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

smarty Cross-site Scripting vulnerability in Javascript escapingGHSA-7j98-h7fp-4vwj

HIGHFix: smarty-php/smarty@6856624

GHSA-7j98-h7fp-4vwj is a high-severity (CVSS 7.1) Cross-site Scripting (XSS) vulnerability in smarty/smarty. A fix is available for smarty/smarty — see the affected versions and patch details below.

Also known asCVE-2023-28447
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.24%0.72%1.21%1.69%0.7%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘smarty/smarty🐘smarty/smarty

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user.

Patches

Please upgrade to the most recent version of Smarty v3 or v4.

For more information

If you have any questions or comments about this advisory please open an issue in the Smarty repo

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsmarty/smarty≥ 4.0.0&&< 4.3.14.3.1composer require smarty/smarty:^4.3.1
🐘Packagistsmarty/smartyall versions3.1.48composer require smarty/smarty:^3.1.48

Affected Products

2 products · 5 configurations
OS
fedorafedoraproject
3 versions
363738
Application
smartysmarty
≥ 4.0.0 && < 4.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for smarty/smarty, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update smarty/smarty to 4.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7j98-h7fp-4vwj is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. ### Patches Please upgrade to the most recent version of Smarty v3 or v4. ### For more information If you have any questions or comments about this advisory please open an issue in [the Smarty repo](https://github.com/smarty-php/smarty)
O3 Security · Impact-Aware SCA

Is GHSA-7j98-h7fp-4vwj in your dependencies?

Find it across Packagist, including transitive dependencies.

smarty Cross-site Scripting vulnerability in Javascript…