NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Django cross-site scripting (XSS) attack via user-supplied redirect URLsGHSA-7fq8-4pv5-5w5c

MEDIUMFix: django/django@2342693

GHSA-7fq8-4pv5-5w5c is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Also known asCVE-2015-2317PYSEC-2015-9
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.0%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
2.24%3.38%4.53%5.67%4.3%5.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐍django🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The utils.http.is_safe_url function in Django before 1.4.20, 1.5.x, 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1 does not properly validate URLs, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a control character in a URL, as demonstrated by a \x08javascript: URL.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjangoall versions1.4.20pip install --upgrade 'django==1.4.20'
🐍PyPIdjango≥ 1.5&&< 1.6.111.6.11pip install --upgrade 'django==1.6.11'
🐍PyPIdjango≥ 1.7&&< 1.7.71.7.7pip install --upgrade 'django==1.7.7'
🐍PyPIdjango≥ 1.8a1&&< 1.8c11.8c1pip install --upgrade 'django==1.8c1'

Affected Products

6 products · 53 configurations
OS
ubuntu linuxcanonical
4 versions
10.0412.0414.0414.10
OS
debian linuxdebian
1 version
7.0
Application
djangodjangoproject
≤ 1.4.19
32 versions
1.51.5.11.5.21.5.31.5.41.5.51.5.61.5.71.5.81.5.91.5.101.5.11
OS
fedorafedoraproject
1 version
22
OS
opensuseopensuse
1 version
13.2
OS
solarisoracle
1 version
11.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.4.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7fq8-4pv5-5w5c is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The utils.http.is_safe_url function in Django before 1.4.20, 1.5.x, 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1 does not properly validate URLs, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a control character in a URL, as demonstrated by a \x08javascript: URL.
O3 Security · Impact-Aware SCA

Is GHSA-7fq8-4pv5-5w5c in your dependencies?

Find it across PyPI, including transitive dependencies.

Django cross-site scripting (XSS) attack via user-supplied…