CVE-2015-2317 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in django. A fix is available for django — see the affected versions and patch details below.
Django cross-site scripting (XSS) attack via user-supplied redirect URLs
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The utils.http.is_safe_url function in Django before 1.4.20, 1.5.x, 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1 does not properly validate URLs, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a control character in a URL, as demonstrated by a \x08javascript: URL.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | all versions | 1.4.20pip install --upgrade 'django==1.4.20' |
| 🐍PyPI | django | ≥ 1.5&&< 1.6.11 | 1.6.11pip install --upgrade 'django==1.6.11' |
| 🐍PyPI | django | ≥ 1.7&&< 1.7.7 | 1.7.7pip install --upgrade 'django==1.7.7' |
| 🐍PyPI | django | ≥ 1.8a1&&< 1.8c1 | 1.8c1pip install --upgrade 'django==1.8c1' |
Affected Products
ubuntu linuxcanonicaldebian linuxdebiandjangodjangoprojectfedorafedoraprojectopensuseopensusesolarisoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 1.4.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-2317 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2015-2317 in your dependencies?
Find it across PyPI, including transitive dependencies.