NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

PostCSS line return parsing errorGHSA-7fh5-64p2-3v2j

MEDIUMFix: postcss/postcss@58cc860

GHSA-7fh5-64p2-3v2j is a medium-severity (CVSS 5.3) CWE-74 vulnerability in postcss. A fix is available for postcss — see the affected versions and patch details below.

Also known asCVE-2023-44270
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-7fh5-64p2-3v2j.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.98%1.47%0.2%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

17Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
postcssnpm
412.0Mdownloads / week

Description

An issue was discovered in PostCSS before 8.4.31. It affects linters using PostCSS to parse external Cascading Style Sheets (CSS). There may be \r discrepancies, as demonstrated by @font-face{ font:(\r/*);} in a rule.

This vulnerability affects linters using PostCSS to parse external untrusted CSS. An attacker can prepare CSS in such a way that it will contains parts parsed by PostCSS as a CSS comment. After processing by PostCSS, it will be included in the PostCSS output in CSS nodes (rules, properties) despite being originally included in a comment.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmpostcssall versions8.4.31npm install postcss@8.4.31

Affected Products

1 product · 1 configurations
Application
postcsspostcss
< 8.4.31
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for postcss, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update postcss to 8.4.31 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7fh5-64p2-3v2j is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Moderate impact. Red Hat products in the current affected scope that use the PostCSS component to parse external, untrusted CSS may allow an attacker to craft CSS comments that PostCSS incorrectly interprets as CSS nodes, causing commented content to be emitted as rules or properties. This may result in CSS injection…

Workaround published by Red Hat
There's no known mitigation for this issue. Red Hat recommends to not parse untrusted CSS input using PostCSS.
Source: Red Hat security advisory for GHSA-7fh5-64p2-3v2j (CC BY 4.0)
ProductFixed inAdvisory
Discovery 1 for RHEL 9discovery/discovery-server-rhel9:1.12.0-1RHSA-2025:1249
Red Hat OpenShift Container Platform 4.17openshift4/nmstate-console-plugin-rhel9:v4.17.0-202411261204.p0.gbc40e56.assembly.stream.el9RHSA-2024:10517
Red Hat OpenShift Container Platform 4.17openshift4/ose-networking-console-plugin-rhel9:v4.17.0-202501150934.p0.g0244dff.assembly.stream.el9RHSA-2025:0654
Red Hat OpenShift Container Platform 4.18openshift4/ingress-node-firewall-rhel9:v4.18.0-202501230001.p0.g1e43b4c.assembly.stream.el9RHSA-2024:6121
Red Hat OpenShift Container Platform 4.18openshift4/aws-kms-encryption-provider-rhel9:v4.18.0-202501230001.p0.g088dcaf.assembly.stream.el9RHSA-2024:6122
Red Hat OpenShift Dev Spaces 3 Containersdevspaces/code-rhel9:3.18-6RHSA-2025:0892
Red Hat OpenShift GitOps 1.14openshift-gitops-1/argocd-rhel8:v1.14.3-4RHSA-2025:3069
Red Hat OpenShift Service Mesh 2.5 for RHEL 8openshift-service-mesh/kiali-rhel8:1.73.17-1RHSA-2024:10908

Frequently Asked Questions

An issue was discovered in PostCSS before 8.4.31. It affects linters using PostCSS to parse external Cascading Style Sheets (CSS). There may be `\r` discrepancies, as demonstrated by `@font-face{ font:(\r/*);}` in a rule. This vulnerability affects linters using PostCSS to parse external untrusted CSS. An attacker can prepare CSS in such a way that it will contains parts parsed by PostCSS as a CSS comment. After processing by PostCSS, it will be included in the PostCSS output in CSS nodes (rules, properties) despite being originally included in a comment.
O3 Security · Impact-Aware SCA

Is GHSA-7fh5-64p2-3v2j in your dependencies?

Find it across npm, including transitive dependencies.

PostCSS line return parsing error (Medium 5.3)