Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2021-23368 — postcss

MEDIUMFix: postcss/postcss@8682b1e

CVE-2021-23368 is a medium-severity (CVSS 5.3) vulnerability in postcss. 2 public exploit references exist, so weaponization risk is real. A fix is available for postcss — see the affected versions and patch details below.

Regular Expression Denial of Service in postcss

Also known asGHSA-hwj9-h5mp-3pm3
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.00%1.51%3.02%4.53%0.3%3.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2021-23368 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 398,142 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

16Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
postcssnpm
336.2Mdownloads / week

Description

The npm package postcss from 7.0.0 and before versions 7.0.36 and 8.2.10 is vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmpostcss≥ 7.0.0&&< 7.0.367.0.36npm install postcss@7.0.36
📦npmpostcss≥ 8.0.0&&< 8.2.108.2.10npm install postcss@8.2.10

Affected Products

1 product · 2 configurations
Application
postcsspostcss
≥ 8.0.0 && < 8.2.10
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for postcss, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update postcss to 7.0.36 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-23368 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

In Red Hat OpenShift Container Platform (RHOCP), OpenShift ServiceMesh (OSSM) and Red Hat Advanced Cluster Management for Kubernetes (RHACM) the affected containers are behind OpenShift OAuth authentication. This restricts access to the vulnerable nodejs-postcss library to authenticated users only, therefore the…

ProductFixed inAdvisory
Red Hat OpenShift Container Platform 4.8openshift4/ose-console:v4.8.0-202107010336.p0.git.188a490.assembly.streamRHSA-2021:2438
Red Hat Quay 3quay/quay-rhel8:v3.6.0-62RHSA-2021:3917

Frequently Asked Questions

The npm package `postcss` from 7.0.0 and before versions 7.0.36 and 8.2.10 is vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.
O3 Security · Impact-Aware SCA

Is CVE-2021-23368 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2021-23368: postcss DoS — Fixed in 7.0.36