NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

MCP Inspector proxy server lacks authentication between the Inspector client and proxyGHSA-7f8r-222p-6f5g

Fix: modelcontextprotocol/inspector@50df0e1

GHSA-7f8r-222p-6f5g is a Missing Authentication vulnerability in @modelcontextprotocol/inspector. EPSS puts its 30-day exploitation probability at 44.5% (99th percentile). A fix is available for @modelcontextprotocol/inspector — see the affected versions and patch details below.

Also known asCVE-2025-49596
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-7f8r-222p-6f5g.

EPSS Exploitation Probability

via FIRST.org ↗
44.5%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%19.2%38.5%57.7%3.3%44.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

87other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@modelcontextprotocol/inspectornpm
771Kdownloads / week

Description

The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@modelcontextprotocol/inspectorall versions0.14.1npm install @modelcontextprotocol/inspector@0.14.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @modelcontextprotocol/inspector, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @modelcontextprotocol/inspector to 0.14.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7f8r-222p-6f5g is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

How to detect GHSA-7f8r-222p-6f5g

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-7f8r-222p-6f5g -u https://target
Template
MCP Inspector < 0.14.0 UnauthenticatedRemote Code Execution
Severity
critical
Impact
Unauthenticated attackers can launch arbitrary MCP commands over stdio due to lack of authentication between Inspector client and proxy, enabling remote code execution.
Remediation
Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.

Template by ProjectDiscovery nuclei-templates (ye11oc4t), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities. Credit: Rémy Marot <[email protected]>
O3 Security · Impact-Aware SCA

Is GHSA-7f8r-222p-6f5g in your dependencies?

Find it across npm, including transitive dependencies.

MCP Inspector proxy server lacks authentication between…