CVE-2025-49596 — @modelcontextprotocol/ins…
Fix: modelcontextprotocol/inspector@50df0e1CVE-2025-49596 is a Missing Authentication vulnerability in @modelcontextprotocol/inspector. EPSS puts its 30-day exploitation probability at 44.5% (99th percentile). A fix is available for @modelcontextprotocol/inspector — see the affected versions and patch details below.
MCP Inspector proxy server lacks authentication between the Inspector client and proxy
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-49596.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@modelcontextprotocol/inspectornpmDescription
The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @modelcontextprotocol/inspector | all versions | 0.14.1npm install @modelcontextprotocol/inspector@0.14.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @modelcontextprotocol/inspector, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @modelcontextprotocol/inspector to 0.14.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-49596 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2025-49596
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2025-49596 -u https://target- Template
- MCP Inspector < 0.14.0 UnauthenticatedRemote Code Execution
- Severity
- critical
- Impact
- Unauthenticated attackers can launch arbitrary MCP commands over stdio due to lack of authentication between Inspector client and proxy, enabling remote code execution.
- Remediation
- Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
Template by ProjectDiscovery nuclei-templates (ye11oc4t), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2025-49596 in your dependencies?
Find it across npm, including transitive dependencies.