NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Regular Expression Denial of Service (ReDoS) in ua-parser-jsGHSA-78cj-fxph-m83p

HIGHFix: faisalman/ua-parser-js@809439e

GHSA-78cj-fxph-m83p is a high-severity (CVSS 7.5) vulnerability in ua-parser-js. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for ua-parser-js — see the affected versions and patch details below.

Also known asCVE-2021-27292
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.00%1.43%2.86%4.30%0.3%3.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ua-parser-jsnpm
46.5Mdownloads / week

Description

ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmua-parser-js≥ 0.7.14&&< 0.7.240.7.24npm install ua-parser-js@0.7.24

Affected Products

1 product · 1 configurations
Application
ua-parser-jsua-parser-js_project
≥ 0.7.14 && < 0.7.24
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ua-parser-js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ua-parser-js to 0.7.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-78cj-fxph-m83p is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

While some components do package a vulnerable version of ua-parser-js, access to them requires OpenShift OAuth credentials and hence have been marked with a Low impact. This applies to the following products: - OpenShift Container Platform (OCP) - OpenShift ServiceMesh (OSSM) - Red Hat OpenShift Jaeger (RHOSJ) - Red…

ProductFixed inAdvisory
OpenShift Logging 5.1openshift-logging/kibana6-rhel8:v6.8.1-108RHSA-2022:0226
OpenShift Logging 5.2openshift-logging/kibana6-rhel8:v6.8.1-110RHSA-2022:0230
OpenShift Logging 5.3openshift-logging/kibana6-rhel8:v6.8.1-109RHSA-2022:0227
Red Hat OpenShift Container Platform 4.8openshift4/ose-console:v4.8.0-202107010336.p0.git.188a490.assembly.streamRHSA-2021:2438
Red Hat OpenShift Jaeger 1.24distributed-tracing/jaeger-agent-rhel8:1.24.0-9RHSA-2021:3024

Frequently Asked Questions

ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.
O3 Security · Impact-Aware SCA

Is GHSA-78cj-fxph-m83p in your dependencies?

Find it across npm, including transitive dependencies.

Regular Expression Denial of Service (ReDoS) in…