CVE-2021-27292 is a high-severity (CVSS 7.5) vulnerability in ua-parser-js. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for ua-parser-js — see the affected versions and patch details below.
Regular Expression Denial of Service (ReDoS) in ua-parser-js
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
ua-parser-jsnpmDescription
ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | ua-parser-js | ≥ 0.7.14&&< 0.7.24 | 0.7.24npm install ua-parser-js@0.7.24 |
Affected Products
ua-parser-jsua-parser-js_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ua-parser-js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ua-parser-js to 0.7.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-27292 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
While some components do package a vulnerable version of ua-parser-js, access to them requires OpenShift OAuth credentials and hence have been marked with a Low impact. This applies to the following products: - OpenShift Container Platform (OCP) - OpenShift ServiceMesh (OSSM) - Red Hat OpenShift Jaeger (RHOSJ) - Red…
| Product | Fixed in | Advisory |
|---|---|---|
| OpenShift Logging 5.1 | openshift-logging/kibana6-rhel8:v6.8.1-108 | RHSA-2022:0226 |
| OpenShift Logging 5.2 | openshift-logging/kibana6-rhel8:v6.8.1-110 | RHSA-2022:0230 |
| OpenShift Logging 5.3 | openshift-logging/kibana6-rhel8:v6.8.1-109 | RHSA-2022:0227 |
| Red Hat OpenShift Container Platform 4.8 | openshift4/ose-console:v4.8.0-202107010336.p0.git.188a490.assembly.stream | RHSA-2021:2438 |
| Red Hat OpenShift Jaeger 1.24 | distributed-tracing/jaeger-agent-rhel8:1.24.0-9 | RHSA-2021:3024 |
Frequently Asked Questions
Is CVE-2021-27292 in your dependencies?
Find it across npm, including transitive dependencies.