NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Cross-Site Scripting in glanceGHSA-7375-vjr2-3g7w

MEDIUMFix: jarofghosts/glance@cdc68bb

GHSA-7375-vjr2-3g7w is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in glance. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for glance — see the affected versions and patch details below.

Also known asCVE-2018-3748
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.95%1.43%0.3%0.9%0.9%Jun 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
glancenpm
438downloads / week

Description

There is a Stored XSS vulnerability in the glance node module versions <= 3.0.5. File name, which contains malicious HTML (eg. embedded iframe element or javascript: pseudo-protocol handler in <a> element) allows to execute JavaScript code against any user who opens a directory listing containing such crafted file name.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmglanceall versions3.0.8npm install glance@3.0.8

Affected Products

1 product · 1 configurations
Application
glanceglance_project
1 version
3.0.5
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for glance, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update glance to 3.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7375-vjr2-3g7w is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Versions of `glance` before 3.0.8 are vulnerable to Stored Cross-Site Scripting (XSS). This is only exploitable if the attacker is able to control the name of a file that is served by the `glance` package.
O3 Security · Impact-Aware SCA

Is GHSA-7375-vjr2-3g7w in your dependencies?

Find it across npm, including transitive dependencies.

Cross-Site Scripting in glance (Medium 6.1)