XWiki Platform vulnerable to cross-site request forgery (CSRF) via the REST APIGHSA-6xxr-648m-gch6
CRITICALFix: xwiki/xwiki-platform@4c17540GHSA-6xxr-648m-gch6 is a critical-severity (CVSS 9.6) Cross-Site Request Forgery (CSRF) vulnerability in org.xwiki.platform:xwiki-platform-rest-server. A fix is available for org.xwiki.platform:xwiki-platform-rest-server — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-6xxr-648m-gch6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-rest-server☕com.xpn.xwiki.platform:xwiki-core-rest-server☕com.xpn.xwiki.platform:xwiki-rest☕org.xwiki.platform:xwiki-platform-rest-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The REST API allows executing all actions via POST requests and accepts text/plain, multipart/form-data or application/www-form-urlencoded as content types which can be sent via regular HTML forms, thus allowing cross-site request forgery. With the interaction of a user with programming rights, this allows remote code execution through script macros and thus impacts the integrity, availability and confidentiality of the whole XWiki installation.
For regular cookie-based authentication, the vulnerability is mitigated by SameSite cookie restrictions but as of March 2023, these are not enabled by default in Firefox and Safari.
Patches
The vulnerability has been patched in XWiki 14.10.8 and 15.2 by requiring a CSRF token header for certain request types that are susceptible to CSRF attacks.
Workarounds
It is possible to check for the Origin header in a reverse proxy to protect the REST endpoint from CSRF attacks, see the Jira issue for an example configuration.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-rest-server | ≥ 1.8&&< 14.10.8 | 14.10.8org.xwiki.platform:xwiki-platform-rest-server:14.10.8 |
| ☕Maven | com.xpn.xwiki.platform:xwiki-core-rest-server | ≥ 1.8&&< 14.10.8 | 14.10.8com.xpn.xwiki.platform:xwiki-core-rest-server:14.10.8 |
| ☕Maven | com.xpn.xwiki.platform:xwiki-rest | ≥ 1.8&&< 14.10.8 | 14.10.8com.xpn.xwiki.platform:xwiki-rest:14.10.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-rest-server | ≥ 15.0-rc-1&&< 15.2 | 15.2org.xwiki.platform:xwiki-platform-rest-server:15.2 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-rest-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-rest-server to 14.10.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6xxr-648m-gch6 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-6xxr-648m-gch6 in your dependencies?
Find it across Maven, including transitive dependencies.