Doctrine SQL injection vulnerabilityGHSA-6q9v-4hq6-5m67
GHSA-6q9v-4hq6-5m67 is a security vulnerability in doctrine/orm. A fix is available for doctrine/orm — see the affected versions and patch details below.
Real-World Exposure
doctrine/orm🐘doctrine/ormReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Doctrine is prone to SQL injection vulnerability. Users of Doctrine 1.2 and 2 should update to the newly released versions of both libraries immediately. Both versions only include the security fix and no other changes to their previous versions 1.2.3 and 2.0.2.
Affected versions are:
- 1.2.3 and earlier for PostgreSQL and DB2 Dialects
- 2.0.2 and earlier
The security issue was found to affect the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery() function which does not cast input values for limit and offset to integer and allows malicious SQL to be executed if these parameters are passed into Doctrine 2 directly from request variables without previous cast to integer. Functionality building on top using limit queries in the ORM such as Doctrine\ORM\Query::setFirstResult() and Doctrine\ORM\Query::setMaxResults() are also affected by this security issue.
The fix for this security issue breaks backwards compatibility for developers that extend the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery() method, because it is now marked as final. Please overwrite the Doctrine\DBAL\Platforms\AbstractPlatform::doModifyLimitQuery() method instead.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | doctrine/orm | ≥ 2.0.0&&< 2.0.3 | 2.0.3composer require doctrine/orm:^2.0.3 |
| 🐘Packagist | doctrine/orm | ≥ 1.0.0&&< 1.2.4 | 1.2.4composer require doctrine/orm:^1.2.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for doctrine/orm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update doctrine/orm to 2.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6q9v-4hq6-5m67 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is GHSA-6q9v-4hq6-5m67 in your dependencies?
Find it across Packagist, including transitive dependencies.