CVE-2015-5723 — annotations
HIGHCVE-2015-5723 is a high-severity (CVSS 7.8) CWE-264 vulnerability in doctrine/annotations. A fix is available for doctrine/annotations — see the affected versions and patch details below.
Doctrine Security Misconfiguration Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
doctrine/annotations🐘doctrine/cache🐘doctrine/common🐘doctrine/common🐘doctrine/orm🐘doctrine/mongodb-odm🐘doctrine/mongodb-odm-bundle🐘zendframework/zendframework1+6 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Doctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8 or 2.5.x before 2.5.1, MongoDB ODM before 1.0.2, and MongoDB ODM Bundle before 3.0.1 use world-writable permissions for cache directories, which allows local users to execute arbitrary PHP code with additional privileges by leveraging an application with the umask set to 0 and that executes cache entries as code.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | doctrine/annotations | all versions | 1.2.7composer require doctrine/annotations:^1.2.7 |
| 🐘Packagist | doctrine/cache | ≥ 1.4.0&&< 1.4.2 | 1.4.2composer require doctrine/cache:^1.4.2 |
| 🐘Packagist | doctrine/common | all versions | 2.4.3composer require doctrine/common:^2.4.3 |
| 🐘Packagist | doctrine/common | ≥ 2.5.0-stable&&< 2.5.1 | 2.5.1composer require doctrine/common:^2.5.1 |
| 🐘Packagist | doctrine/orm | ≥ 2.5.0&&< 2.5.1 | 2.5.1composer require doctrine/orm:^2.5.1 |
| 🐘Packagist | doctrine/mongodb-odm | all versions | 1.0.2composer require doctrine/mongodb-odm:^1.0.2 |
Affected Products
debian linuxdebianannotationsdoctrine-projectcachedoctrine-projectcommondoctrine-projectdoctrinemongodbbundledoctrine-projectmongodb-odmdoctrine-projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for doctrine/annotations, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update doctrine/annotations to 1.2.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5723 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2015-5723 in your dependencies?
Find it across Packagist, including transitive dependencies.