NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Memory exhaustion in HashiCorp VaultGHSA-6p62-6cg9-f5f5

HIGHFix: hashicorp/vault#24354

GHSA-6p62-6cg9-f5f5 is a high-severity (CVSS 7.5) CWE-770 vulnerability in github.com/hashicorp/vault. A fix is available for github.com/hashicorp/vault — see the affected versions and patch details below.

Also known asBIT-vault-2023-6337CVE-2023-6337GO-2023-2399
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.29%0.69%1.10%1.50%1.0%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹github.com/hashicorp/vault🐹github.com/hashicorp/vault🐹github.com/hashicorp/vault

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

HashiCorp Vault and Vault Enterprise 1.12.0 and newer are vulnerable to a denial of service through memory exhaustion of the host when handling large unauthenticated and authenticated HTTP requests from a client. Vault will attempt to map the request to memory, resulting in the exhaustion of available memory on the host, which may cause Vault to crash.

Fixed in Vault 1.15.4, 1.14.8, 1.13.12.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/hashicorp/vault≥ 1.15.0&&< 1.15.41.15.4go get github.com/hashicorp/vault@v1.15.4
🐹Gogithub.com/hashicorp/vault≥ 1.14.0&&< 1.14.81.14.8go get github.com/hashicorp/vault@v1.14.8
🐹Gogithub.com/hashicorp/vault≥ 1.12.0&&< 1.13.121.13.12go get github.com/hashicorp/vault@v1.13.12

Affected Products

1 product · 8 configurations
Application
vaulthashicorp
≥ 1.15.0 && ≤ 1.12.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/vault, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/hashicorp/vault to 1.15.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6p62-6cg9-f5f5 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

HashiCorp Vault and Vault Enterprise 1.12.0 and newer are vulnerable to a denial of service through memory exhaustion of the host when handling large unauthenticated and authenticated HTTP requests from a client. Vault will attempt to map the request to memory, resulting in the exhaustion of available memory on the host, which may cause Vault to crash. Fixed in Vault 1.15.4, 1.14.8, 1.13.12.
O3 Security · Impact-Aware SCA

Is GHSA-6p62-6cg9-f5f5 in your dependencies?

Find it across Go, including transitive dependencies.

Memory exhaustion in HashiCorp Vault (High 7.5)