CVE-2023-6337 is a high-severity (CVSS 7.5) CWE-770 vulnerability in github.com/hashicorp/vault. A fix is available for github.com/hashicorp/vault — see the affected versions and patch details below.
Vault May be Vulnerable to a Denial of Service Through Memory Exhaustion When Handling Large HTTP Requests
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/vault🐹github.com/hashicorp/vault🐹github.com/hashicorp/vaultReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
HashiCorp Vault and Vault Enterprise 1.12.0 and newer are vulnerable to a denial of service through memory exhaustion of the host when handling large unauthenticated and authenticated HTTP requests from a client. Vault will attempt to map the request to memory, resulting in the exhaustion of available memory on the host, which may cause Vault to crash.
Fixed in Vault 1.15.4, 1.14.8, 1.13.12.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/vault | ≥ 1.15.0&&< 1.15.4 | 1.15.4go get github.com/hashicorp/vault@v1.15.4 |
| 🐹Go | github.com/hashicorp/vault | ≥ 1.14.0&&< 1.14.8 | 1.14.8go get github.com/hashicorp/vault@v1.14.8 |
| 🐹Go | github.com/hashicorp/vault | ≥ 1.12.0&&< 1.13.12 | 1.13.12go get github.com/hashicorp/vault@v1.13.12 |
Affected Products
vaulthashicorpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/vault, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/vault to 1.15.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6337 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2023-6337 in your dependencies?
Find it across Go, including transitive dependencies.