Exposure of Sensitive Information in eventsourceGHSA-6h5x-7c5m-7cr7
CRITICALFix: EventSource/eventsource#273GHSA-6h5x-7c5m-7cr7 is a critical-severity (CVSS 9.3) CWE-212 vulnerability in eventsource. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for eventsource — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
eventsourcenpmDescription
When fetching an url with a link to an external site (Redirect), the users Cookies & Autorisation headers are leaked to the third party application. According to the same-origin-policy, the header should be "sanitized."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | eventsource | all versions | 1.1.1npm install eventsource@1.1.1 |
| 📦npm | eventsource | ≥ 2.0.0&&< 2.0.2 | 2.0.2npm install eventsource@2.0.2 |
Affected Products
debian linuxdebianeventsourceeventsourceResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for eventsource, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update eventsource to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6h5x-7c5m-7cr7 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| .NET Core on Red Hat Enterprise Linux | rh-dotnet31-dotnet-0:3.1.422-1.el7_9 | RHSA-2022:6037 |
| .NET Core on Red Hat Enterprise Linux | rh-dotnet60-dotnet-0:6.0.107-1.el7_9 | RHBA-2022:5721 |
| OpenShift Service Mesh 2.1 | openshift-service-mesh/kiali-rhel8:1.36.10-2 | RHSA-2022:5006 |
| Red Hat Ceph Storage 6.1 | rhceph/rhceph-6-dashboard-rhel9:6-75 | RHSA-2023:3642 |
| Red Hat Enterprise Linux 8 | dotnet6.0-0:6.0.107-1.el8_6 | RHBA-2022:5747 |
| Red Hat Enterprise Linux 8 | dotnet3.1-0:3.1.422-1.el8_6 | RHSA-2022:6057 |
| Red Hat Enterprise Linux 9 | dotnet6.0-0:6.0.107-1.el9_0 | RHBA-2022:5749 |
| Red Hat Fuse Online 7.10.2.P1 | eventsource | RHSA-2022:5030 |
Frequently Asked Questions
Is GHSA-6h5x-7c5m-7cr7 in your dependencies?
Find it across npm, including transitive dependencies.