Drupal OAuth2 Client Cross-Site Request Forgery (CSRF)GHSA-6chf-hhqf-749c
MEDIUMGHSA-6chf-hhqf-749c is a medium-severity (CVSS 6.8) Cross-Site Request Forgery (CSRF) vulnerability in drupal/oauth2_client. A fix is available for drupal/oauth2_client — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-6chf-hhqf-749c.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/oauth2_clientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal OAuth2 Client allows Cross Site Request Forgery. This issue affects OAuth2 Client: from 0.0.0 before 4.1.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/oauth2_client | all versions | 4.1.3composer require drupal/oauth2_client:^4.1.3 |
Affected Products
oauth2 clientmskccDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/oauth2_client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/oauth2_client to 4.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6chf-hhqf-749c is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-6chf-hhqf-749c in your dependencies?
Find it across Packagist, including transitive dependencies.