Drupal core Denial of Service vulnerabilityGHSA-6ccv-8fgf-cjpw
Fix: drupal/core@2f76ac7GHSA-6ccv-8fgf-cjpw is a security vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Real-World Exposure
drupal/core🐘drupal/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The Comment module allows users to reply to comments. In certain cases, an attacker could make comment reply requests that would trigger a denial of service (DOS).
Sites that do not use the Comment module are not affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.0.0&&< 10.1.8 | 10.1.8composer require drupal/core:^10.1.8 |
| 🐘Packagist | drupal/core | ≥ 10.2.0&&< 10.2.2 | 10.2.2composer require drupal/core:^10.2.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 10.1.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6ccv-8fgf-cjpw is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-6ccv-8fgf-cjpw in your dependencies?
Find it across Packagist, including transitive dependencies.