Deserialization of Untrusted Data in Apache DubboGHSA-69wp-3pm3-hxgg
Fix: apache/dubbo@9b18fe2GHSA-69wp-3pm3-hxgg is a Deserialization of Untrusted Data vulnerability in org.apache.dubbo:dubbo-rpc-http-invoker. 8 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.dubbo:dubbo-rpc-http-invoker — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.dubbo:dubbo-rpc-http-invokerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Unsafe deserialization occurs within a Dubbo application which has HTTP remoting enabled. An attacker may submit a POST request with a Java object in it to completely compromise a Provider instance of Apache Dubbo, if this instance enables HTTP. This issue affected Apache Dubbo 2.7.0 to 2.7.4, 2.6.0 to 2.6.7, and all 2.5.x versions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.dubbo:dubbo-rpc-http-invoker | ≥ 2.5.0&&< 2.7.5 | 2.7.5org.apache.dubbo:dubbo-rpc-http-invoker:2.7.5 |
Affected Products
dubboapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Unsafe deserialization occurs within a Dubbo application which has HTTP …
Report on github.com
Report on github.com
Report on github.com
Report on 1665891.fs1.hubspotusercontent-na1.net
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.dubbo:dubbo-rpc-http-invoker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.dubbo:dubbo-rpc-http-invoker to 2.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-69wp-3pm3-hxgg is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
How to detect GHSA-69wp-3pm3-hxgg
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-69wp-3pm3-hxgg -u https://target- Template
- Apache Dubbo 2.5.x-2.7.4 - Insecure Deserialization
- Severity
- critical
- Impact
- Unauthenticated attackers can exploit unsafe deserialization to execute arbitrary code on Dubbo Provider instances with HTTP remoting enabled, leading to complete server compromise.
- Remediation
- Upgrade to Apache Dubbo version 2.7.5 or later, or disable HTTP remoting if not required.
Template by ProjectDiscovery nuclei-templates (Khalid6468), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-69wp-3pm3-hxgg in your dependencies?
Find it across Maven, including transitive dependencies.