NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2019-17564 — dubbo-rpc-http-invoker

CRITICALFix: apache/dubbo@9b18fe2

CVE-2019-17564 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in org.apache.dubbo:dubbo-rpc-http-invoker. 8 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.dubbo:dubbo-rpc-http-invoker — see the affected versions and patch details below.

Deserialization of Untrusted Data in Apache Dubbo

Also known asGHSA-69wp-3pm3-hxgg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
8 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
36.5%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
17.7%45.1%72.6%100.0%94.0%36.5%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.dubbo:dubbo-rpc-http-invoker

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Unsafe deserialization occurs within a Dubbo application which has HTTP remoting enabled. An attacker may submit a POST request with a Java object in it to completely compromise a Provider instance of Apache Dubbo, if this instance enables HTTP. This issue affected Apache Dubbo 2.7.0 to 2.7.4, 2.6.0 to 2.6.7, and all 2.5.x versions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.dubbo:dubbo-rpc-http-invoker≥ 2.5.0&&< 2.7.52.7.5org.apache.dubbo:dubbo-rpc-http-invoker:2.7.5

Affected Products

1 product · 3 configurations
Application
dubboapache
≥ 2.7.0 && ≤ 2.7.4
range
Exploits & PoCs
8

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.dubbo:dubbo-rpc-http-invoker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.dubbo:dubbo-rpc-http-invoker to 2.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-17564 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

How to detect CVE-2019-17564

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2019-17564 -u https://target
Template
Apache Dubbo 2.5.x-2.7.4 - Insecure Deserialization
Severity
critical
Impact
Unauthenticated attackers can exploit unsafe deserialization to execute arbitrary code on Dubbo Provider instances with HTTP remoting enabled, leading to complete server compromise.
Remediation
Upgrade to Apache Dubbo version 2.7.5 or later, or disable HTTP remoting if not required.

Template by ProjectDiscovery nuclei-templates (Khalid6468), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Unsafe deserialization occurs within a Dubbo application which has HTTP remoting enabled. An attacker may submit a POST request with a Java object in it to completely compromise a Provider instance of Apache Dubbo, if this instance enables HTTP. This issue affected Apache Dubbo 2.7.0 to 2.7.4, 2.6.0 to 2.6.7, and all 2.5.x versions.
O3 Security · Impact-Aware SCA

Is CVE-2019-17564 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-17564: dubbo-rpc-http-invoker — Fixed in 2.7.5