NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

SQL injection in moodleGHSA-69c3-5xxf-58q2

CRITICALFix: moodle/moodle@a0f47c8

GHSA-69c3-5xxf-58q2 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Also known asBIT-moodle-2022-30599CVE-2022-30599
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.79%1.34%1.89%2.44%1.9%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in moodle where an SQL injection risk was identified in Badges code relating to configuring criteria.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.0&&< 4.0.14.0.1composer require moodle/moodle:^4.0.1
🐘Packagistmoodle/moodle≥ 3.11&&< 3.11.73.11.7composer require moodle/moodle:^3.11.7
🐘Packagistmoodle/moodle≥ 3.10&&< 3.10.113.10.11composer require moodle/moodle:^3.10.11
🐘Packagistmoodle/moodle≥ 3.9&&< 3.9.143.9.14composer require moodle/moodle:^3.9.14

Affected Products

3 products · 8 configurations
OS
fedorafedoraproject
3 versions
343536
Application
moodlemoodle
≥ 3.11 && < 3.11.7
1 version
4.0.0
OS
enterprise linuxredhat
1 version
8.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-69c3-5xxf-58q2 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

A flaw was found in moodle where an SQL injection risk was identified in Badges code relating to configuring criteria.
O3 Security · Impact-Aware SCA

Is GHSA-69c3-5xxf-58q2 in your dependencies?

Find it across Packagist, including transitive dependencies.

SQL injection in moodle (Critical 9.8)