CVE-2022-30599 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
SQL injection in moodle
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in moodle where an SQL injection risk was identified in Badges code relating to configuring criteria.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 4.0&&< 4.0.1 | 4.0.1composer require moodle/moodle:^4.0.1 |
| 🐘Packagist | moodle/moodle | ≥ 3.11&&< 3.11.7 | 3.11.7composer require moodle/moodle:^3.11.7 |
| 🐘Packagist | moodle/moodle | ≥ 3.10&&< 3.10.11 | 3.10.11composer require moodle/moodle:^3.10.11 |
| 🐘Packagist | moodle/moodle | ≥ 3.9&&< 3.9.14 | 3.9.14composer require moodle/moodle:^3.9.14 |
Affected Products
fedorafedoraprojectmoodlemoodleenterprise linuxredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-30599 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2022-30599 in your dependencies?
Find it across Packagist, including transitive dependencies.